Aller au contenu principal

CALQUE

Bouton : LAYER
Ruban : Début » Calques » Propriétés du calque ou Outils » Palettes » Propriétés du calque
Barre d'outils : Calques » Gestionnaire des propriétés des calques
Menu : Format » Calque ou Outils » Palettes » Propriétés du calque
Clavier : CALQUE
Alias : CA、LA ou DDLMODES

Crée ou gère le calque, et modifie sa couleur, son type de ligne et d'autres propriétés.

Entrer CALQUE en ligne de commande et appuyer sur Entrée pour ouvrir la palette du Gestionnaire des propriétés des calques.

Entrer -CALQUE dans la ligne de commande et appuyer sur Entrée, le système s'exécutera en suivant la ligne de commande.

Liste​

Énumère les calques existants du dessin en cours dans la barre de commande ou dans la fenêtre de texte, y compris les informations pertinentes telles que le nom du calque, la couleur, le type de ligne, le statut, etc.

Nouveau​

Crée un ou plusieurs calques.

Etablir​

Crée un nouveau calque et le définit comme calque courant.

Choisir​

Spécifie le calque existant en tant que calque courant.

Couleur​

Modifie la couleur du calque.

Couleurs vraies​

Définissez la couleur en fonction des valeurs de rouge, vert et bleu.

Carnet de couleurs​

Définissez la couleur à partir des carnets de couleurs chargés.

Tligne​

Modifiez le type de ligne du calque.

Epaisseur de ligne​

Modifiez l'épaisseur de ligne du calque. Si la valeur saisie n'est pas valide, l'épaisseur de ligne actuelle est définie sur la valeur d'épaisseur de ligne valide la plus proche.

Tracer​

Contrôle le tracé du calque visible lorsque le calque est ouvert.

Tracer​

Activez le tracé des calques visibles.

Ne pas tracer​

Désactivez le tracé des calques visibles.

Pstyle​

Modifiez le style de tracé du calque. Uniquement valide lors de l'utilisation du mode Style de tracé nommé.

Actif​

Ouvre le calque spécifié.

Inactif​

Ferme le calque spécifié.

Geler​

Gèle le calque spécifié.

Libérer​

Dégèle le calque spécifié.

Verrouiller​

Verrouille le calque spécifié.

Déverrouiller​

Déverrouille le calque spécifié.

Renommer​

Renommez le calque spécifié.

Description​

Ajoutez une description textuelle ou remplacez la description textuelle existante pour le calque spécifié.

Supprimer​

Supprimez le calque spécifié.

État​

Enregistrez l'état du calque dans le dessin.

? - Liste​

Listez les états de calque nommés dans le dessin.

Sauver​

Enregistrez l'état du calque dans le dessin avec le nom spécifié.

Restaurer​

Restaure les paramètres de l’état du calque et les propriétés du calque aux paramètres enregistrés auparavant.

Nom​

Modifiez le nom de l'état du calque enregistré.

Supprimer​

Supprimez l'état de calque enregistré.

Transparence​

Modifiez la transparence du calque spécifié.

Référence associée​

alette du Gestionnaire des propriétés des calques​

Crée ou gère le calque, modifie sa couleur, son type de ligne et d'autres propriétés.

Lister calque​

Affiche les calques correspondant aux conditions spécifiées et leurs attributs pertinents, qui comprennent le nom, activé, geler, verrouiller, couleur, type de ligne, type de ligne, épaisseur de ligne, style de tracé, tracé et ainsi de suite. Les utilisateurs peuvent modifier directement les attributs en cliquant avec la souris sur les attributs affichés dans la liste.

Etat​

Affiche le type de calque : filtre de calque, calque utilisé, calque nul ou calque courant.

Nom​

Affiche le nom du calque.

Actif​

Affiche si le calque est ouvert ou fermé. Le calque fermé n'est ni visible ni imprimable, même si vous activez l'option Tracé.

Geler​

Affiche si les calques de toutes les fenêtres sont gelés ou non. Les objets sur le calque verrouillé ne sont pas affichés, imprimés, cachés ou régénérés, ce qui vous permet de réduire le temps de régénération en verrouillant le calque.

Verrouillé​

Affiche si le calque est verrouillé ou non.

Couleur​

Afficher la couleur du calque, cliquer sur l'attribut, la boîte de dialogue"Sélectionner la couleur" sera ouverte, et les utilisateurs pourront en spécifier les couleurs.

Couleur de fenêtre​

Définissez le remplacement de couleur du calque sélectionné dans la fenêtre de présentation actuelle. L'option n'est valide que si elle est utilisée dans la présentation.

Type de ligne​

Afficher le type de ligne de la couche, cliquer sur l'attribut, la boîte de dialogue "Gestionnaire de types de ligne" sera ouverte, et les utilisateurs pourront en spécifier le type de ligne.

Type de ligne de fenêtre​

Définissez le remplacement de type de ligne du calque sélectionné dans la fenêtre de présentation actuelle. L'option n'est valide que si elle est utilisée dans la présentation.

Epaisseur de ligne​

Afficher l'épaisseur de ligne du calque, cliquer sur l'attribut, la boîte de dialogue "Hauteur de ligne" sera ouverte, et les utilisateurs pourront en spécifier l'épaisseur de ligne.

Epaisseur de ligne de fenêtre​

Définissez le remplacement d'épaisseur de ligne du calque sélectionné dans la fenêtre de présentation actuelle. L'option n'est valide que si elle est utilisée dans la présentation.

Transparence​

Affichez la transparence du calque. Cliquez sur l'attribut pour ouvrir la boîte de dialogue Transparence des calques, dans laquelle vous pouvez spécifier la valeur de transparence du calque.

Viewport Transparency​

Définissez le remplacement de la transparence du calque sélectionné dans la fenêtre de la présentation actuelle. L'option n'est valide que si elle est utilisée dans la présentation.

Style de tracé​

Afficher le style de tracé du calque, cliquer sur l'attribut, la boîte de dialogue "Sélectionner le style de tracé" sera ouverte, et les utilisateurs pourront y définir le style de tracé. Cependant, lorsque la valeur de la variable système PSTYLEPOLICYest 1, et que le style de tracé correspondant à la couleur est utilisé, le style de tracé associatif au calque ne peut pas être modifié.

Style de tracé de fenêtre​

Définissez le remplacement du style de tracé du calque sélectionné dans la fenêtre de présentation actuelle. L'option n'est valide que si elle est utilisée dans la présentation.

Tracé​

Affiche si le calque sélectionné doit être imprimé. La fermeture du tracé n'est valable que pour les calques ouverts et gelés que vous avez sélectionnés. Si un calque doit être imprimé, mais qu'il est gelé ou fermé dans le dessin en cours, alors le calque ne peut pas être imprimé. Si le calque contient des informations de référence, l'impression du calque doit être fermée.

Nouveau gel de fenêtre​

Gèle le calque sélectionné dans la nouvelle fenêtre . Si le calque est réglé sur Nouvelle Fenêtre Gelée, le calque est verrouillé dans les nouvelles vues créées, mais n'a aucun effet sur les vues existantes.

Gel de la fenêtre​

Gèle le calque sélectionné dans la fenêtre actuelle. Les calques de la fenêtre actuelle peuvent être gelés ou non gelés, ce qui n'a aucune influence sur la visibilité des calques dans les autres fenêtres. Les calques congelés sont invisibles, qui n'ont pas pu être régénérés ou imprimés. "Dégeler" pourrait restaurer la visibilité des calques. Et l'option n'est valable que si elle est utilisée dans la présentation.

Description​

Décrit le calque et le filtre de calque.

Nouvelle propriété de filtre​

Lancer la boîte de dialogue "Filtre des propriété de calques", et filtrer les calques dans les conditions désignées.

Nouveau filtre de groupe​

Crée un filtre de calque, qui inclura les calques sélectionnés et ajoutés au filtre.

Liste des filtres​

Spécifie le calque à afficher dans la liste des calques. Vous pouvez afficher les calques Tous, Tous les calques utilisés et les calques Xref-dépendants.

Filtre inversé​

Si vous cochez cette option, les calques seront affichés selon les critères opposés définis par le filtre.

Gestionnaire des Etats de Calques​

Lancer la boîte de dialogue "Gestionnaire des états de calques" enregistrer l'état actuel du calque et le restaurer si nécessaire.

Nouveau calque​

Crée un nouveau calque. Le nouveau calque créé est affiché à la fin de la liste des calques et hérite des propriétés du calque sélectionné.

Supprimer le calque​

Supprime le calque sélectionné de la liste des états de calque.

Stocké dans la variable système CLAYER.

Définir calque courant​

Définit le calque sélectionné dans la liste des calques comme calque courant.

Actualiser​

Actualise l'ordre de la liste des calques et les informations sur l'état des calques.

Paramètres​

Affiche la boîte de dialogue Paramètres de calque, dans laquelle vous pouvez définir différentes options d'affichage.

Calque courant​

Affiche le nom du calque courant.

Chercher un calque​

Lors de la saisie de caractères, filtrer rapidement les calques en saisissant le nom du calque.

Barre d'état​

Affichez le nom du filtre de calque actuel, le nombre de calques affichés dans l'arborescence de la liste et le nombre total de calques dans le dessin.

Boîte de dialogue Paramètres de calque​

Réglez les calques de référence externes et les affichages alternatifs.

Paramètres de calque xréf​

Conservation des remplacements de propriétés de calques xréf​

Contrôle l'affichage des remplacements de propriétés de calques. Les propriétés des calques dépendant des xréfs ne sont pas rechargées. Les modifications apportées aux propriétés des calques xréf sont conservées.

Stocké dans la variable système VISRETAIN.

Propriétés de calques xréf à recharger (à l'exception des remplacements)​

Active le rechargement automatique des propriétés des calques xrefs.

Stocké dans la variable système VISRETAINMODE.

Activé/Désactivé​

Le paramètre de calque xréf Activé/Désactivé est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Geler/Libérer​

Le paramètre de calque xréf Geler/Libérer est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Verrouillé/Déverrouillé​

Le paramètre de calque xréf Verrouiller/Déverrouiller est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Tracer/Ne pas tracer​

Le paramètre de calque xréf Tracer/Ne pas tracer est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Gel dans les nouvelles fenêtres​

Le paramètre de calque xréf Geler/Libérer des nouvelles fenêtres est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Description​

Le paramètre de calque xréf de description Verrouiller/Déverrouiller est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Couleur​

Le paramètre de calque xréf Couleur est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Type de ligne​

Le paramètre de calque xréf Type de ligne est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Epaisseur de ligne​

Le paramètre de calque xréf Epaisseur de ligne est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Transparence​

Le paramètre de calque xréf Transparence est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Style de tracé​

Le paramètre de calque xréf Style de tracé est rechargé automatiquement pour correspondre aux paramètres des calques du dessin xréf.

Ne conservez pas les remplacements de propriétés de calque xréf​

Contrôle les propriétés des calques dépendant des xréfs. Toutes les modifications apportées aux calques dépendant des xréfs dans le dessin actuel sont valables uniquement pendant la session actuelle et ne sont pas enregistrées dans le dessin.

Stocké dans la variable système VISRETAIN.

Traitement des propriétés de l'objet xréf en tant que DuCalque​

Contrôle l'affichage des propriétés d'objet sur les calques référencés. Les objets sont traités comme si leurs propriétés étaient définies sur DuCalque et chaque calque de référence externe peut disposer de ses propres remplacements de calque.

Stocké dans la variable système XREFOVERRIDE.

Remplacement des paramètres d'affichage​

Activation de la couleur d'arrière-plan des remplacements de propriétés de calque​

Couleur de fond de contrôle alternative surlignée pour référence externe.

Stocké dans la variable système LAYEROVERRIDEHIGHLIGHT.

Couleur d'arrière-plan du remplacement de xréf​

Affiche la liste des couleurs et la boîte de dialogue Sélectionner une couleur permettant de choisir une couleur d'arrière-plan pour les remplacements xréf.

Utilisation de la commande CALQUE​

Pour faire d'un calque sélectionné le calque courant​

  1. Dans la barre d'outils Calques, cliquer sur le Contrôle des calques.

  2. Cliquer sur le nom du calque que vous voulez utiliser.

Pour faire du calque d'un objet sélectionné le calque courant​

  1. Dans la barre d'outils Calques, cliquer sur Faire le calque courant de l'objet.

  2. Sélectionner un objet.

    Le calque de l'objet que vous avez sélectionné est maintenant le calque courant.

Pour activer et désactiver un calque​

  1. Dans la barre d'outils Calques, cliquer sur le Contrôle des calques.

  2. Cliquer sur l'ampoule pour le nom du calque que vous voulez allumer ou éteindre.

    Si l'ampoule est jaune, le calque est allumé.

Pour affecter une couleur à un calque​

  1. Dans le menu Format, cliquer sur Calque.

  2. Dans le Gestionnaire des propriétés des calques, sélectionner un calque et cliquer sur l'icône de couleur.

  3. Dans la boîte de dialogue Sélectionner la couleur, choisir une couleur.

  4. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.

Pour modifier les propriétés de plus d'un calque​

  1. Dans le menu Format, cliquer sur Calque.

  2. Dans le Gestionnaire des propriétés des calques, utiliser l'une des méthodes suivantes pour sélectionner les calques :

  • Maintenir la touche Ctrl enfoncée et sélectionner les noms de calque.

  • Faire un clic droit et cliquer sur Afficher les filtres dans la liste des calques pour afficher une coche, puis sélectionner un filtre de calque.

  1. Cliquer sur les icônes des propriétés que vous souhaitez modifier.

  2. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.

Pour créer un nouveau calque​

  1. Dans le menu Format, cliquer sur Calque.

  2. Dans le Gestionnaire des propriétés des calques, cliquer sur le bouton Nouveau calque. Un nom de calque, tel que LAYER1, est automatiquement ajouté à la liste des calques.

  3. Entrer un nouveau nom de calque en tapant sur le nom du calque surligné. Un nom de calque peut comprendre jusqu'à 255 caractères : lettres, chiffres et les caractères spéciaux, tels que le signe du dollar ($), le trait d'union (-) et le soulignement (_). Utiliser une guillemet inversé (`) avant les autres caractères spéciaux afin que les caractères ne soient pas interprétés comme des caractères génériques. Les noms de calques ne peuvent pas inclure d'espaces vides.

  4. Pour modifier les propriétés, cliquer sur les icônes.

    Lorsque vous cliquez sur Couleur, Type de ligne, Epaisseur de ligne ou Style de tracé, une boîte de dialogue s'affiche.

  5. (Facultatif) Cliquer dans la colonne Description et entrer le texte.

  6. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.

Pour supprimer un calque inutilisé​

  1. Dans la barre d'outils Calques, cliquer sur Calque.

  2. Dans le Gestionnaire des propriétés des calques, sélectionner le calque et cliquer sur le bouton Supprimer le calque. Les calques auxquels sont affectés des objets ne peuvent pas être supprimés tant que ces objets ne sont pas réaffectés à un autre calque ou supprimés. Les calques 0 et DEFPOINTS et le calque courant ne peuvent pas être supprimés.

  3. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.Le calque sélectionné est supprimé.

Pour purger tous les calques inutilisés​

  1. Dans le menu Fichier, cliquer sur Utilitaires de dessin. »Purger.

  2. Dans le Gestionnaire des propriétés des calques, cliquer sur le bouton Nouveau calque. Un nom de calque, tel que LAYER1, est automatiquement ajouté à la liste des calques.

  • Pour purger tous les calques non référencés, sélectionner Calques.

  • Pour purger des calques spécifiques, double-cliquer sur les calques pour développer l'arborescence. Sélectionner les calques à purger.

  1. Si l'élément que vous souhaitez purger n'est pas répertorié, sélectionner Afficher les éléments que vous ne pouvez pas purger, sélectionner le calque et lire l'explication.

  2. Vous êtes invité à confirmer chaque élément de la liste. Si vous ne voulez pas confirmer chaque purge, décocher l'option Confirmer chaque élément à purger.

  3. Cliquer sur Purger.

  4. Pour confirmer la purge de chaque élément, répondre à l'invite en choisissant Oui ou Non, ou Oui à Tous si plus d'un élément est sélectionné.

  5. Cliquer sur Fermer.

Pour modifier le calque d'un ou plusieurs objets​

  1. Sélectionner les objets dont vous voulez modifier le calque.

  2. Dans la barre d'outils Calques, cliquer sur le Contrôle des calques.

  3. Sélectionner le calque que vous voulez affecter aux objets.

  4. Appuyer sur ESC pour supprimer la sélection.

Pour changer le type de ligne par défaut assigné à un calque, procéder comme suit​

  1. Dans le menu Format, cliquer sur Calque.

  2. Dans le Gestionnaire des propriétés des calques, sélectionner le type de ligne pour le calque que vous voulez changer. La boîte de dialogue Sélectionner le type de ligne s'affiche.

  3. Si le type de ligne dont vous avez besoin n'est pas affiché dans la boîte de dialogue Sélectionner le type de ligne, cliquer sur Charger et utiliser l'une des méthodes suivantes :

  • Dans la boîte de dialogue Charger ou Reload Linetypes, sélectionner un ou plusieurs types de ligne à charger et cliquer sur OK pour revenir à la boîte de dialogue Sélectionner le type de ligne.

  • Dans la boîte de dialogue Charger ou Recharger les types de ligne, cliquer sur Fichier pour ouvrir d'autres fichiers de définition de type de ligne (LIN). Sélectionner un ou plusieurs types de ligne à charger et cliquer sur OK pour revenir à la boîte de dialogue Sélectionner le type de ligne.

  1. Sélectionner le type de ligne que vous voulez utiliser et cliquer sur OK pour retourner au Gestionnaire des propriétés des calques.
  2. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.

Pour renommer un calque​

  1. Dans le menu Format, cliquer sur Calque.

  2. Dans le Gestionnaire des propriétés des calques, sélectionner un calque et cliquer sur le nom ou appuyer sur F2.

  3. Entrer un nouveau nom.

  4. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.

Pour renommer plus d'un calque​

  1. Sur la ligne de commande, entrer renommer.

  2. Dans la boîte de dialogue Renommer, dans la liste Objets nommés, sélectionner Calques.

  3. Dans Ancien nom, entrer l'ancien nom, en utilisant des caractères génériques ; par exemple, entrer stairs$*.

  4. Dans Renommer à, entrer le nouveau nom en utilisant des caractères génériques ; par exemple, entrer s_*. Les résultats pour cet exemple sont les suivants : les calques STAIR$LEVEL-1, STAIR$LEVEL-2, STAIR$LEVEL-3 sont renommés S_LEVEL-1, S_LEVEL-2, S_LEVEL-3.

  5. Cliquer sur Renommer pour appliquer les modifications et continuer, ou cliquer sur OK.

Pour annuler les modifications apportées aux paramètres de calque​

  • Dans la barre d'outils Calques, cliquer sur Calque précédent.

La ligne de commande affiche le message "État du calque précédent restauré".

Remarque

CALQUEP ne restaure pas les calques supprimés ou purgés et ne supprime pas un calque qui a été ajouté. Si vous renommez un calque et changez ses propriétés, Calque Précédent restaure les propriétés d'origine mais pas le nom du calque d'origine.

Pour filtrer rapidement l'affichage des calques par nom​

  1. Dans le menu Format, cliquer sur Calque.

  2. Dans le Gestionnaire des propriétés des calques, cliquer sur Rechercher un calque sous l'arborescence.

  3. (Facultatif) Pour limiter votre recherche, sélectionner un filtre de calque dans l'arborescence.

  4. Entrer une chaîne de caractères, y compris les caractères génériques.

    La vue en liste affiche tous les calques dont le nom correspond à la chaîne de caractères. Par exemple, si vous saisissez *mech*, tous les calques avec les lettres mech dans leurs noms sont affichés.

Ce filtre rapide est supprimé lorsque le Gestionnaire de propriétés des calques se ferme.

Pour filtrer l'affichage des noms de calque en sélectionnant les calques​

  1. Dans le menu Format, cliquer sur Calque.
  2. Dans le Gestionnaire des propriétés des calques, cliquer sur le bouton Nouveau filtre de propriétés.
  3. Dans la boîte de dialogue Propriétés du filtre de calque, entrer un nom pour le filtre.
  4. Sous Définition du filtre, définir les propriétés du calque que vous voulez utiliser pour définir le filtre.
  • Pour filtrer par nom, utiliser des caractères génériques.

  • Pour filtrer par propriété, cliquer dans la colonne de la propriété que vous voulez.

Certaines propriétés affichent une boîte de dialogue lorsque vous cliquez sur le bouton [....].

  • Pour sélectionner plus d'une valeur pour une propriété, faire un clic droit sur la ligne dans la définition du filtre, cliquer sur Dupliquer la ligne et sélectionner une autre valeur pour cette propriété dans la ligne suivante.
  1. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.

Pour filtrer l'affichage des noms de calque en sélectionnant les calques​

  1. Dans la barre d'outils Calques, cliquer sur Gestionnaire de propriétés des calques.

  2. Dans le Gestionnaire des propriétés des calques, cliquer sur le bouton Nouveau filtre de groupe.

    Un nouveau filtre de groupe de calques nommé GROUP FILTER1 est créé dans l'arborescence.

  3. Saisir un nom pour le filtre.

  4. Dans l'arborescence, cliquer sur Tous ou sur l'un des autres nœuds pour afficher les calques dans la vue en liste.

  5. Dans la vue en liste, sélectionner les calques que vous voulez ajouter au filtre et les faire glisser vers le nom du filtre dans l'arborescence.

  6. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.

Pour imbriquer un filtre de calque sous un autre filtre de calque​

  1. Dans la barre d'outils Calques, cliquer sur Gestionnaire de propriétés des calques.
  2. Dans l'arborescence du Gestionnaire des propriétés des calques, sélectionner un filtre de calque.
  • Un nouveau filtre de propriété de calque peut être imbriqué sous un filtre de groupe ou un autre filtre de propriété.

  • Un nouveau filtre de groupe de calques ne peut être imbriqué que sous un autre filtre de groupe.

  1. Faire un clic droit et choisir Nouveau filtre de propriétés ou Nouveau filtre de groupe dans le menu contextuel.

  2. Utiliser l'une des méthodes suivantes :

  • Pour un nouveau filtre de propriétés, la boîte de dialogue Filtre des propriétés des calques s'affiche. Sous Définition du filtre, définir les propriétés du calque que vous voulez utiliser pour définir le filtre, puis cliquer sur OK.

  • Pour un nouveau filtre de groupe, un filtre est ajouté à l'arborescence. Renommer, sélectionner le filtre parent pour afficher ses calques dans la vue liste, et faire glisser les calques de la vue liste vers le nouveau filtre de groupe de calques.

  1. Cliquer sur Appliquer pour enregistrer vos modifications, ou cliquer sur OK pour enregistrer et fermer.

Pour supprimer un calque d'un filtre de groupe de calques​

  1. Dans la barre d'outils Calques, cliquer sur Gestionnaire de propriétés des calques.

  2. Dans l'arborescence du Gestionnaire des propriétés des calques, sélectionner un filtre de groupe.

  3. Sélectionner le calque que vous voulez supprimer.

  4. Faire un clic droit dans la liste, puis cliquer sur Supprimer du filtre de groupe dans le menu contextuel.