STYLETABLEAU
Bouton :
Ruban (2D) : Début » Annotation » Style de tableau ou Outils » Paramètres de style » Style de tableau
Ruban (3D) : Outils » Paramètres de style » Style de tableau
Barre d'outils : Styles » Style de tableau
Menu : Format » Style de tableau
Clavier : STYLETABLEAU
Alias : TS
Crée ou modifie le style de tableau spécifié.
Saisir TABLESTYLE dans la ligne de commande et appuyer sur Entrée, la boîte de dialogue Style de tableau s'affiche, dans lequel vous pouvez définir le style de table actuel, créer un nouveau style de table, modifier ou supprimer un style de table existant et renommer un style de table spécifié.
Référence associée
Boîte de dialogue Style de tableau
Définit le style de tableau actuel, crée un nouveau style de tableau, modifie ou supprime un style de tableau existant, et renomme un style de tableau spécifié.
Style de tableau courant
Affiche le nom du style de tableau actuel.
Liste de style
Affiche tous les styles de tableau qui correspondent aux conditions de filtrage. Le style actuel sera mis en évidence.
Liste
Contrôle l'affichage des styles de tableau dans la liste Styles.
Tous les styles
Affiche tous les styles de tableau disponibles.
Styles utilisés
Afficher uniquement le style de tableau actuel et le style de tableau standard.
Aperçu de
Affiche un aperçu du style de tableau sélectionné dans la liste Styles, qui peut être modifié pour répondre à vos besoins.
Définir courant
Définit le style de tableau sélectionné comme style courant, qui deviendra le style de base pour les nouveaux tableaux.
Nouveau
Ouvrir la boîte de dialogue Créer un nouveau style de tableau dans laquelle vous pouvez créer un nouveau style de tableau.
Modifier
Ouvrir la boîte de dialogue Modifier le style de tableau dans lequel vous pouvez modifier le style de tableau actuel.
Effacer
Supprime le style de tableau sélectionné. Si le style de tableau sélectionné est utilisé, le bouton sera gris.
Boîte de dialogue Créer un nouveau style de tableau
Saisir un nom pour le nouveau style de tableau et spécifier le style de base utilisé pour créer un nouveau style de tableau.
Nom du nouveau style
Saisir un nom pour le nouveau style de tableau.
Commencer par
Spécifie le style de base utilisé pour créer le nouveau style de tableau.
Continuer
Ouvrir la boîte de dialogue Nouveau style de tableau dans laquelle vous pouvez définir le nouveau style de tableau.
Boîte de dialogue Nouveau/Modifier le style du tableau
Définit un nouveau style de tableau ou modifie le style de tableau actuellement sélectionné.
Tableau de départ
Sélectionnez un tableau comme échantillon pour mettre en forme le style du tableau, spécifier la structure et le contenu à copier, ou supprimer le tableau de départ.
Général
Définit les informations générales du style de table.
Direction du tableau
Change la direction d'un tableau. La direction de la table inclut le haut et le bas.
Haut
Crée un tableau que vous devez lire de bas en haut. La ligne de titre et la ligne d'en-tête de colonne se trouvent au bas du tableau.
Bas
Crée un tableau que vous devez lire de haut en bas. La ligne de titre et la ligne d'en-tête de colonne se trouvent en haut du tableau.
Aperçu
Affiche un aperçu du style de tableau que vous avez défini.
Styles de cellule
Crée un nouveau style de table ou modifie un style de tableau existant.
Menu déroulant Styles de cellules
Afficher les styles de cellules disponibles dans le tableau.
Créer un style de cellule Bouton
Ouvrir la boîte de dialogue Créer un style de cellule dans laquelle vous pouvez spécifier le nom et le style de base pour le nouveau style de cellule.
Gérer les styles de cellule Bouton
Ouvrir la boîte de dialogue Gérer les styles de cellule dans laquelle vous pouvez créer, supprimer ou renommer des styles de cellule.
Style de cellule Onglet
L'onglet Style de cellule comprend trois options : Général, Texte et Bordures.
Général
Propriétés
Couleur de remplissage
Spécifie la couleur de remplissage de la cellule. La valeur par défaut est Défaut.
Alignement
Définit l'alignement du texte dans la cellule.
Format de unités
Définit le format du texte dans la cellule. Cliquer sur le bouton "...." pour ouvrir la boîte de dialogue Format dans laquelle vous pouvez définir les options de formatage.
Type
Spécifie le type de style de cellule comme Données ou Étiquette.
Marges
Spécifie l'espacement entre le contenu de la cellule et les bordures. L'espacement horizontal et vertical est par défaut de 1,5 (métrique) ou 0,06 (pouce).
Horizontale
Spécifie l'espacement entre le contenu de la cellule et les bords gauche et droit de la cellule.
Verticale
Spécifie l'espacement entre le contenu de la cellule et les bords inférieur et supérieur de la cellule.
Fusionner les cellules par rangée/colonne
Fusionne toutes les nouvelles lignes ou colonnes en une seule cellule.
Texte
Style de texte
Spécifie le style du texte dans la cellule.
Style de texte Bouton
Ouvrir la boîte de dialogue Style de texte dans laquelle vous pouvez créer ou modifier des styles de texte.
Le réglage est sauvegardé dans la variable système DIMTXSTY.
Hauteur de texte
Spécifie la hauteur du texte dans la cellule. La hauteur du texte par défaut pour le titre du tableau est 6 (métrique) ou 0,25 (pouce), et pour l'en-tête de colonne et les données est 4,5 (métrique) ou 0,18 (pouce).
Couleur du texte
Spécifie la couleur du texte dans la cellule.
Angle du texte
Spécifie l'angle du texte dans la cellule. La valeur par défaut est 0 degré et la valeur varie de -359 à +359 degrés.
Bordures
Epaisseur de ligne
Spécifie la hauteur de ligne de la bordure de la cellule. Si vous voulez utiliser une ligne épaisse, les marges des cellules peuvent être augmentées.
Type de ligne
Spécifie le type de ligne de la bordure de la cellule. Cliquer sur le bouton Autre dans la liste déroulante pour charger un type de ligne personnalisé.
Couleur
Spécifie la couleur de la bordure de la cellule.
Ligne double
Spécifie que les bordures de tableau sont affichées sous forme de lignes doubles.
Espacement
Spécifie l'espacement pour les bordures de lignes doubles. La valeur par défaut est 1,125 (métrique) ou 0,045 (pouce).
Boutons de bordure
Contrôle l'apparence des bords des cellules.
Toutes les bordures
Applique les paramètres de bordure à toutes les bordures.
Bordures extérieures
Applique les paramètres de bordure aux bordures extérieures.
Bordures intérieures
Applique les paramètres de bordure aux bordures intérieures.
Bordure inférieure
Applique les paramètres de bordure aux bordures inférieures.
Bordure gauche
Applique les paramètres de bordure aux bordures de gauche.
Bordure supérieure
Applique les paramètres de bordure aux bordures supérieures.
Bordure droite
Applique les paramètres de bordure aux bords droits.
Aucune bordure
N'applique les paramètres de bordure à aucune bordure.
Aperçu du style de cellule
Affiche l'aperçu du style de cellule que vous avez défini.
Boîte de dialogue Créer un nouveau style de cellule
Spécifie le nom et le style de base pour le nouveau style de cellule.
Nom du nouveau style
Spécifie un nom pour le nouveau style de cellule.
Commencer par
Spécifie le style de base utilisé pour créer le nouveau style de cellule.
Continuer
Revenir à la boîte de dialogue Nouveau/Modifier le style de tableau dans laquelle vous pouvez définir le nouveau style de cellule.
Boîte de dialogue Gérer les styles de cellules
Crée, renomme ou supprime des styles de cellules.
Styles de cellule
Énumère tous les styles de cellules dans le style de tableau actuel. Chaque style de table contient trois styles de cellules : Titre, En-tête et Données.
Nouveau
Ouvrir la boîte de dialogue Créer un style de cellule ddans laquelle vous pouvez spécifier le nom et le style de base pour le nouveau style de cellule.
Renommer
Renomme le style de cellule sélectionné. Les styles Titre, En-tête et Cellule de données ne peuvent pas être renommés.
Effacer
Supprime le style de cellule sélectionné. Les styles Titre, En-tête et Cellule de données ne peuvent pas être supprimés.
Aperçu du style de cellule
Affiche l'aperçu du style de cellule que vous avez défini.
Boîte de dialogue Format
Définit le format des différents types de données.
Type de données
Affiche une liste de types de données, y compris Angle, Monnaie, Date, Nombre décimal, Général, Entier, Pourcentage, Point et Texte.
Aperçu
Affiche un aperçu de l'effet de l'option sélectionnée dans la liste Format.
Format des unités
Énumère les informations pertinentes sur le format en fonction du type de données sélectionné. Par exemple, si vous sélectionnez Nombre décimal comme type de données, des options telles que Unités actuelles, Décimal, Architectural et ainsi de suite seront affichées dans la liste Format.
Précision
Définit la précision des formats disponibles. Uniquement pour les types de données en pourcentage, points, angles et nombres décimaux.
Séparateur de liste
Spécifie le séparateur (virgule, point-virgule ou barre oblique) entre les points. Uniquement pour le type de données Point.
Coordonnées X, Y et Z
Filtre le point des coordonnées X, Y ou Z. Uniquement pour le type de données Point.
Symbole
Spécifie le symbole de la devise. Uniquement pour le type de données de devise.
Condition de matière
Placer le symbole du pourcentage ou le symbole de la monnaie après le chiffre. Uniquement pour les types de données en pourcentage et en devise.
Nombres négatifs
Précise une représentation négative. Uniquement pour le type de données de devise.
Format supplémentaire
Ouvrir la boîte de dialogue Format supplémentaire dans laquelle vous pouvez définir les options pour d'autres formats dans la cellule de tableau. Uniquement pour les types de données Pourcentage, Point, Devise, Angle, Nombre décimal et Entier.
Exemples
Affiche une liste de formats pour l'affichage des données. Uniquement pour le type de données Date.
Utilisation de la commande STYLETABLEAU
Pour définir un style de tableau
- Cliquer sur Outils onglet » Paramètres de style panel » Style de tableau.
- Dans la boîte de dialogue Gestionnaire de Style de Tableau, cliquer sur Nouveau.
- Dans la boîte de dialogue Créer un nouveau style de tableau, entrer un nom pour le nouveau style de tableau et sélectionner un style dans le menu déroulant Commencer par, pour fournir des paramètres par défaut pour le nouveau style de tableau. Cliquer sur Continuer.
- Dans la boîte de dialogue Nouveau style de tableau, définir les options suivantes :
- Définir la direction du tableau en sélectionnant Haut ou Bas dans le menu déroulant.
- Spécifier le style de cellule du tableau à partir du menu déroulant Styles de cellule.
- Dans les onglets Général, Texte et Bordures, définir les options pertinentes pour le style de cellule actuel.
- Cliquer sur OK pour terminer la création d'un nouveau style de tableau.